{"cve":"CVE-2020-2112","nvd":{"published":"2020-02-12T15:15:12.710","modified":"2026-06-17T03:11:46.840","status":"Modified","description":"Jenkins Git Parameter Plugin 0.9.11 and earlier does not escape the parameter name shown on the UI, resulting in a stored cross-site scripting vulnerability exploitable by users with Job/Configure permission.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2020/02/12/3","https://jenkins.io/security/advisory/2020-02-12/#SECURITY-1709","http://www.openwall.com/lists/oss-security/2020/02/12/3","https://jenkins.io/security/advisory/2020-02-12/#SECURITY-1709"],"products":["jenkins:git_parameter"],"source":"nvd","synced_at":"2026-10-19T21:02:53.949909883+00:00"},"epss":{"cve":"CVE-2020-2112","score":0.00735,"percentile":0.54446,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-hw26-fw67-qxm9","url":"https://osv.dev/vulnerability/GHSA-hw26-fw67-qxm9","summary":"Jenkins Git Parameter Plugin vulnerable to Stored cross-site scripting (XSS)","modified":"2024-02-16T08:22:40.425630Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.tools:git-parameter","purl":"pkg:maven/org.jenkins-ci.tools/git-parameter","ranges":["<0.9.12"],"fixed":["0.9.12"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}