{"cve":"CVE-2020-19850","nvd":{"published":"2023-04-04T15:15:07.897","modified":"2026-06-17T02:59:58.690","status":"Modified","description":"An issue found in Directus API v.2.2.0 allows a remote attacker to cause a denial of service via a great amount of HTTP requests.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","score":6.5},"cwes":["CWE-400"],"references":["https://github.com/directus/api/issues/982","https://github.com/directus/api/issues/982"],"products":["monospace:directus"],"source":"nvd","synced_at":"2026-10-19T21:37:48.383111019+00:00"},"epss":{"cve":"CVE-2020-19850","score":0.01079,"percentile":0.65069,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-3gvp-54v2-2jrp","url":"https://osv.dev/vulnerability/GHSA-3gvp-54v2-2jrp","summary":"Directus API vulnerable to denial of service","modified":"2023-11-08T04:02:48.070401Z","packages":[{"ecosystem":"npm","name":"directus","purl":"pkg:npm/directus","ranges":[">=2.2.0 <2.2.1"],"fixed":["2.2.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}