{"cve":"CVE-2020-19000","nvd":{"published":"2021-08-27T19:15:07.357","modified":"2026-06-17T02:59:32.760","status":"Modified","description":"Cross Site Scripting (XSS) in Simiki v1.6.2.1 and prior allows remote attackers to execute arbitrary code via line 54 of the component 'simiki/blob/master/simiki/generators.py'.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/tankywoo/simiki/issues/123","https://github.com/tankywoo/simiki/issues/123"],"products":["simiki_project:simiki"],"source":"nvd","synced_at":"2026-10-19T21:21:57.125947417+00:00"},"epss":{"cve":"CVE-2020-19000","score":0.01119,"percentile":0.66155,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-fqr5-qphf-vfr8","url":"https://osv.dev/vulnerability/GHSA-fqr5-qphf-vfr8","summary":"Cross Site Scripting (XSS) in Simiki","modified":"2024-10-22T17:22:35.950431Z","packages":[{"ecosystem":"PyPI","name":"simiki","purl":"pkg:pypi/simiki","ranges":["<1.6.2.2"],"fixed":["1.6.2.2"]}]},{"id":"PYSEC-2021-347","url":"https://osv.dev/vulnerability/PYSEC-2021-347","summary":"","modified":"2023-11-08T04:02:44.650058Z","packages":[{"ecosystem":"PyPI","name":"simiki","purl":"pkg:pypi/simiki","ranges":["all versions"],"fixed":[]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}