{"cve":"CVE-2020-1746","nvd":{"published":"2020-05-12T18:15:13.600","modified":"2026-06-17T03:02:19.270","status":"Modified","description":"A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as well as Ansible Tower before and including versions 3.4.5 and 3.5.5 and 3.6.3 when the ldap_attr and ldap_entry community modules are used. The issue discloses the LDAP bind password to stdout or a log file if a playbook task is written using the bind_pw in the parameters field. The highest threat from this vulnerability is data confidentiality.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N","score":5.0},"cwes":["CWE-200"],"references":["https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1746","https://github.com/ansible/ansible/pull/67866","https://www.debian.org/security/2021/dsa-4950","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1746","https://github.com/ansible/ansible/pull/67866"],"products":["debian:debian_linux","redhat:ansible_engine","redhat:ansible_tower"],"source":"nvd","synced_at":"2026-10-19T21:04:18.695612450+00:00"},"epss":{"cve":"CVE-2020-1746","score":0.00393,"percentile":0.33511,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-j2h6-73x8-22c4","url":"https://osv.dev/vulnerability/GHSA-j2h6-73x8-22c4","summary":"Exposure of Sensitive Information to an Unauthorized Actor in ansible","modified":"2024-09-11T17:01:51.876634Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.8.0a1 <2.8.11"],"fixed":["2.8.11"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.9.0a1 <2.9.7"],"fixed":["2.9.7"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.7.0a1 <2.7.17"],"fixed":["2.7.17"]}]},{"id":"PYSEC-2020-13","url":"https://osv.dev/vulnerability/PYSEC-2020-13","summary":"","modified":"2023-11-08T04:02:41.516184Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.7.0 <2.7.17",">=2.8.0 <2.8.11",">=2.9.0 <2.9.7"],"fixed":["2.7.17","2.8.11","2.9.7"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}