{"cve":"CVE-2020-15138","nvd":{"published":"2020-08-07T17:15:10.450","modified":"2026-06-17T02:56:07.577","status":"Modified","description":"Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:L","score":7.5},"cwes":["CWE-79"],"references":["https://github.com/PrismJS/prism/pull/2506/commits/7bd7de05edf71112a3a77f87901a2409c9c5c20c","https://github.com/PrismJS/prism/security/advisories/GHSA-wvhm-4hhf-97x9","https://prismjs.com/plugins/previewers/#disabling-a-previewer","https://github.com/PrismJS/prism/pull/2506/commits/7bd7de05edf71112a3a77f87901a2409c9c5c20c","https://github.com/PrismJS/prism/security/advisories/GHSA-wvhm-4hhf-97x9"],"products":["prismjs:previewers"],"source":"nvd","synced_at":"2026-10-19T21:06:22.076270124+00:00"},"epss":{"cve":"CVE-2020-15138","score":0.02041,"percentile":0.81154,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-wvhm-4hhf-97x9","url":"https://osv.dev/vulnerability/GHSA-wvhm-4hhf-97x9","summary":"Cross-Site Scripting in Prism","modified":"2026-07-08T06:00:45.631865969Z","packages":[{"ecosystem":"npm","name":"prismjs","purl":"pkg:npm/prismjs","ranges":[">=1.1.0 <1.21.0"],"fixed":["1.21.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}