{"cve":"CVE-2020-14365","nvd":{"published":"2020-09-23T13:15:15.470","modified":"2026-06-17T02:54:37.907","status":"Modified","description":"A flaw was found in the Ansible Engine, in ansible-engine 2.8.x before 2.8.15 and ansible-engine 2.9.x before 2.9.13, when installing packages using the dnf module. GPG signatures are ignored during installation even when disable_gpg_check is set to False, which is the default behavior. This flaw leads to malicious packages being installed on the system and arbitrary code executed via package installation scripts. The highest threat from this vulnerability is to integrity and system availability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H","score":7.1},"cwes":["CWE-347"],"references":["https://bugzilla.redhat.com/show_bug.cgi?id=1869154","https://www.debian.org/security/2021/dsa-4950","https://bugzilla.redhat.com/show_bug.cgi?id=1869154","https://www.debian.org/security/2021/dsa-4950"],"products":["debian:debian_linux","redhat:ansible_engine","redhat:ansible_tower","redhat:ceph_storage","redhat:openstack_platform"],"source":"nvd","synced_at":"2026-10-19T21:09:53.489947993+00:00"},"epss":{"cve":"CVE-2020-14365","score":0.00233,"percentile":0.14233,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-m429-fhmv-c6q2","url":"https://osv.dev/vulnerability/GHSA-m429-fhmv-c6q2","summary":"Improper Verification of Cryptographic Signature in ansible","modified":"2024-11-27T05:25:26.969306Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.8.0a1 <2.8.15"],"fixed":["2.8.15"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.9.0a1 <2.9.13"],"fixed":["2.9.13"]}]},{"id":"PYSEC-2020-209","url":"https://osv.dev/vulnerability/PYSEC-2020-209","summary":"","modified":"2023-11-08T04:02:26.657708Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.8.0 <2.8.16rc1",">=2.9.0 <2.9.14rc1"],"fixed":["2.8.16rc1","2.9.14rc1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}