{"cve":"CVE-2020-10684","nvd":{"published":"2020-03-24T14:15:12.327","modified":"2026-06-17T02:48:15.097","status":"Modified","description":"A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H","score":7.1},"cwes":["CWE-862","CWE-94","CWE-362"],"references":["https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-10684","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DKPA4KC3OJSUFASUYMG66HKJE7ADNGFW/","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MRRYUU5ZBLPBXCYG6CFP35D64NP2UB2S/","https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WQVOQD4VAIXXTVQAJKTN7NUGTJFE2PCB/","https://security.gentoo.org/glsa/202006-11"],"products":["debian:debian_linux","fedoraproject:fedora","redhat:ansible","redhat:ansible_tower","redhat:openstack"],"source":"nvd","synced_at":"2026-10-19T21:03:08.679916934+00:00"},"epss":{"cve":"CVE-2020-10684","score":0.00334,"percentile":0.26752,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-p62g-jhg6-v3rq","url":"https://osv.dev/vulnerability/GHSA-p62g-jhg6-v3rq","summary":"Code Injection, Race Condition, and Execution with Unnecessary Privileges in Ansible","modified":"2024-11-27T06:12:03.552043Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.7.0a1 <2.7.17"],"fixed":["2.7.17"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.8.0a1 <2.8.11"],"fixed":["2.8.11"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.9.0a1 <2.9.7"],"fixed":["2.9.7"]}]},{"id":"PYSEC-2020-207","url":"https://osv.dev/vulnerability/PYSEC-2020-207","summary":"","modified":"2023-11-08T04:01:59.204492Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.7.0 <2.7.17",">=2.8.0 <2.8.9",">=2.9.0 <2.9.6"],"fixed":["2.7.17","2.8.9","2.9.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}