{"cve":"CVE-2019-7615","nvd":{"published":"2019-07-30T22:15:12.660","modified":"2026-06-17T02:40:45.920","status":"Modified","description":"A TLS certificate validation flaw was found in Elastic APM agent for Ruby versions before 2.9.0. When specifying a trusted server CA certificate via the 'server_ca_cert' setting, the Ruby agent would not properly verify the certificate returned by the APM server. This could result in a man in the middle style attack against the Ruby agent.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","score":7.4},"cwes":["CWE-295"],"references":["https://www.elastic.co/community/security/","https://www.elastic.co/community/security/"],"products":["elastic:apm-agent-ruby"],"source":"nvd","synced_at":"2026-10-19T20:58:11.797917892+00:00"},"epss":{"cve":"CVE-2019-7615","score":0.00644,"percentile":0.50898,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-35j2-p8fh-x966","url":"https://osv.dev/vulnerability/GHSA-35j2-p8fh-x966","summary":"Elastic APM agent for Ruby vulnerable to Improper Certificate Validation","modified":"2024-02-16T08:23:31.243119Z","packages":[{"ecosystem":"RubyGems","name":"elastic-apm","purl":"pkg:gem/elastic-apm","ranges":["<2.9.0"],"fixed":["2.9.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}