{"cve":"CVE-2019-5729","nvd":{"published":"2019-03-21T16:01:05.797","modified":"2026-06-17T02:38:07.340","status":"Modified","description":"Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","score":8.1},"cwes":["CWE-295"],"references":["https://www.splunk.com/view/SP-CAAAQAD","https://www.splunk.com/view/SP-CAAAQAD"],"products":["splunk:software_development_kit"],"source":"nvd","synced_at":"2026-10-19T20:55:22.313337056+00:00"},"epss":{"cve":"CVE-2019-5729","score":0.00702,"percentile":0.5327,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-f58w-649r-qjr9","url":"https://osv.dev/vulnerability/GHSA-f58w-649r-qjr9","summary":"splunk-sdk does not properly verify untrusted TLS server certificates","modified":"2024-10-27T15:50:08.557828Z","packages":[{"ecosystem":"PyPI","name":"splunk-sdk","purl":"pkg:pypi/splunk-sdk","ranges":["<1.6.6"],"fixed":["1.6.6"]}]},{"id":"PYSEC-2019-203","url":"https://osv.dev/vulnerability/PYSEC-2019-203","summary":"","modified":"2023-11-08T04:01:37.141304Z","packages":[{"ecosystem":"PyPI","name":"splunk-sdk","purl":"pkg:pypi/splunk-sdk","ranges":["<1.6.6"],"fixed":["1.6.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}