{"cve":"CVE-2019-16760","nvd":{"published":"2019-09-30T22:15:10.313","modified":"2026-06-17T02:22:44.610","status":"Modified","description":"Cargo prior to Rust 1.26.0 may download the wrong dependency if your package.toml file uses the `package` configuration key. Usage of the `package` key to rename dependencies in `Cargo.toml` is ignored in Rust 1.25.0 and prior. When Rust 1.25.0 and prior is used Cargo may download the wrong dependency, which could be squatted on crates.io to be a malicious package. This not only affects manifests that you write locally yourself, but also manifests published to crates.io. Rust 1.0.0 through Rust 1.25.0 is affected by this advisory because Cargo will ignore the `package` key in manifests. Rust 1.26.0 through Rust 1.30.0 are not affected and typically will emit an error because the `package` key is unstable. Rust 1.31.0 and after are not affected because Cargo understands the `package` key. Users of the affected versions are strongly encouraged to update their compiler to the latest available one. Preventing this issue from happening requires updating your compiler to be either Rust 1.26.0 or newer. There will be no point release for Rust versions prior to 1.26.0. Users of Rust 1.19.0 to Rust 1.25.0 can instead apply linked patches to mitigate the issue.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","score":7.5},"cwes":["CWE-494","CWE-16"],"references":["http://www.openwall.com/lists/oss-security/2019/10/08/3","https://gist.github.com/pietroalbini/0d293b24a44babbeb6187e06eebd4992","https://github.com/rust-lang/rust/security/advisories/GHSA-phjm-8x66-qw4r","https://groups.google.com/forum/#%21topic/rustlang-security-announcements/rVQ5e3TDnpQ","http://www.openwall.com/lists/oss-security/2019/10/08/3"],"products":["rust-lang:rust"],"source":"nvd","synced_at":"2026-10-19T20:59:10.855360465+00:00"},"epss":{"cve":"CVE-2019-16760","score":0.0126,"percentile":0.69624,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9f3p-wvj7-q82x","url":"https://osv.dev/vulnerability/GHSA-9f3p-wvj7-q82x","summary":"Cargo prior to Rust 1.26.0 may download the wrong dependency","modified":"2026-09-10T03:49:38.253152249Z","packages":[{"ecosystem":"crates.io","name":"cargo","purl":"pkg:cargo/cargo","ranges":["<0.27.0"],"fixed":["0.27.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}