{"cve":"CVE-2019-16548","nvd":{"published":"2019-11-21T15:15:14.727","modified":"2026-06-17T02:22:24.620","status":"Modified","description":"A cross-site request forgery vulnerability in Jenkins Google Compute Engine Plugin 4.1.1 and earlier in ComputeEngineCloud#doProvision could be used to provision new agents.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-352"],"references":["http://www.openwall.com/lists/oss-security/2019/11/21/1","https://jenkins.io/security/advisory/2019-11-21/#SECURITY-1586","http://www.openwall.com/lists/oss-security/2019/11/21/1","https://jenkins.io/security/advisory/2019-11-21/#SECURITY-1586"],"products":["jenkins:google_compute_engine"],"source":"nvd","synced_at":"2026-10-19T20:59:25.448946135+00:00"},"epss":{"cve":"CVE-2019-16548","score":0.00691,"percentile":0.5283,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-x24m-wr2f-p3vc","url":"https://osv.dev/vulnerability/GHSA-x24m-wr2f-p3vc","summary":"Jenkins Google Compute Engine Plugin Cross-Site Request Forgery vulnerability","modified":"2024-02-16T08:03:39.811037Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:google-compute-engine","purl":"pkg:maven/org.jenkins-ci.plugins/google-compute-engine","ranges":["<4.2.0"],"fixed":["4.2.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}