{"cve":"CVE-2019-16538","nvd":{"published":"2019-11-21T15:15:13.947","modified":"2026-06-17T02:22:23.473","status":"Modified","description":"A sandbox bypass vulnerability in Jenkins Script Security Plugin 1.67 and earlier related to the handling of default parameter expressions in closures allowed attackers to execute arbitrary code in sandboxed scripts.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-863"],"references":["http://www.openwall.com/lists/oss-security/2019/11/21/1","https://jenkins.io/security/advisory/2019-11-21/#SECURITY-1658","http://www.openwall.com/lists/oss-security/2019/11/21/1","https://jenkins.io/security/advisory/2019-11-21/#SECURITY-1658"],"products":["jenkins:script_security"],"source":"nvd","synced_at":"2026-10-19T20:59:25.448946135+00:00"},"epss":{"cve":"CVE-2019-16538","score":0.01416,"percentile":0.72771,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-62pm-mgrh-7p69","url":"https://osv.dev/vulnerability/GHSA-62pm-mgrh-7p69","summary":"Incorrect Authorization in Jenkins Script Security Plugin","modified":"2024-02-16T07:59:44.637624Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:script-security","purl":"pkg:maven/org.jenkins-ci.plugins/script-security","ranges":["<1.68"],"fixed":["1.68"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}