{"cve":"CVE-2019-15477","nvd":{"published":"2019-08-23T13:15:10.827","modified":"2026-06-17T02:20:26.710","status":"Modified","description":"Jooby before 1.6.4 has XSS via the default error handler.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/jooby-project/jooby/pull/1368","https://github.com/jooby-project/jooby/pull/1368"],"products":["jooby:jooby"],"source":"nvd","synced_at":"2026-10-19T20:58:39.700375520+00:00"},"epss":{"cve":"CVE-2019-15477","score":0.00984,"percentile":0.62339,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-f5f4-m7qp-w6gc","url":"https://osv.dev/vulnerability/GHSA-f5f4-m7qp-w6gc","summary":"Cross-site Scripting in Jooby","modified":"2024-02-16T08:00:41.882519Z","packages":[{"ecosystem":"Maven","name":"org.jooby:jooby","purl":"pkg:maven/org.jooby/jooby","ranges":["<1.6.4"],"fixed":["1.6.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}