{"cve":"CVE-2019-14905","nvd":{"published":"2020-03-31T17:15:26.013","modified":"2026-06-17T02:19:17.563","status":"Modified","description":"A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on NXOS devices. Malicious code could craft the filename parameter to perform OS command injections. This could result in a loss of confidentiality of the system among other issues.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:L","score":5.6},"cwes":["CWE-668","CWE-20","CWE-73"],"references":["http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html","http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html","https://access.redhat.com/errata/RHSA-2020:0216","https://access.redhat.com/errata/RHSA-2020:0218","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14905"],"products":["fedoraproject:fedora","opensuse:backports_sle","opensuse:leap","redhat:ansible_engine","redhat:ansible_tower","redhat:ceph_storage","redhat:cloudforms_management_engine","redhat:openstack"],"source":"nvd","synced_at":"2026-10-19T21:03:08.679916934+00:00"},"epss":{"cve":"CVE-2019-14905","score":0.00713,"percentile":0.53661,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-frxj-5j27-f8rf","url":"https://osv.dev/vulnerability/GHSA-frxj-5j27-f8rf","summary":"Externally Controlled Reference to a Resource in Another Sphere, Improper Input Validation, and External Control of File Name or Path in Ansible","modified":"2024-11-25T05:25:15.851785Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.7.0a1 <2.7.16"],"fixed":["2.7.16"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.8.0a1 <2.8.8"],"fixed":["2.8.8"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.9.0a1 <2.9.3"],"fixed":["2.9.3"]}]},{"id":"PYSEC-2020-206","url":"https://osv.dev/vulnerability/PYSEC-2020-206","summary":"","modified":"2023-11-08T04:01:12.383959Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.7.0 <2.7.16",">=2.8.0 <2.8.8",">=2.9.0 <2.9.3"],"fixed":["2.7.16","2.8.8","2.9.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}