{"cve":"CVE-2019-14858","nvd":{"published":"2019-10-14T15:15:09.927","modified":"2026-06-17T02:19:10.957","status":"Modified","description":"A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub parameters marked as no_log, passing an invalid parameter name to the module will cause the task to fail before the no_log options in the sub parameters are processed. As a result, data in the sub parameter fields will not be masked and will be displayed if Ansible is run with increased verbosity and present in the module invocation arguments for the task.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","score":5.5},"cwes":["CWE-532","CWE-117"],"references":["http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html","http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html","https://access.redhat.com/errata/RHSA-2019:3201","https://access.redhat.com/errata/RHSA-2019:3202","https://access.redhat.com/errata/RHSA-2019:3203"],"products":["redhat:ansible_engine","redhat:ansible_tower"],"source":"nvd","synced_at":"2026-10-19T20:59:10.855360465+00:00"},"epss":{"cve":"CVE-2019-14858","score":0.00424,"percentile":0.36702,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-h653-95qw-h2mp","url":"https://osv.dev/vulnerability/GHSA-h653-95qw-h2mp","summary":"Ansible leaks sensitive information to logs when told not to","modified":"2024-09-10T22:06:17.528452Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.9.0a1 <2.9.0rc4"],"fixed":["2.9.0rc4"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.8.0a1 <2.8.6"],"fixed":["2.8.6"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.7.0a1 <2.7.14"],"fixed":["2.7.14"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.0 <2.6.20"],"fixed":["2.6.20"]}]},{"id":"PYSEC-2019-171","url":"https://osv.dev/vulnerability/PYSEC-2019-171","summary":"","modified":"2026-06-10T17:00:18.580471794Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.0 <2.8.1"],"fixed":["2.8.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}