{"cve":"CVE-2019-10436","nvd":{"published":"2019-10-16T14:15:11.277","modified":"2026-06-17T02:10:56.210","status":"Modified","description":"An arbitrary file read vulnerability in Jenkins Google OAuth Credentials Plugin 0.9 and earlier allowed attackers able to configure jobs and credentials in Jenkins to obtain the contents of any file on the Jenkins master.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","score":6.5},"cwes":[],"references":["https://jenkins.io/security/advisory/2019-10-16/#SECURITY-1583","https://jenkins.io/security/advisory/2019-10-16/#SECURITY-1583"],"products":["jenkins:google_oauth_credentials"],"source":"nvd","synced_at":"2026-10-19T20:59:10.855360465+00:00"},"epss":{"cve":"CVE-2019-10436","score":0.00989,"percentile":0.62503,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-8qh4-fghr-6fxg","url":"https://osv.dev/vulnerability/GHSA-8qh4-fghr-6fxg","summary":"Improper Limitation of a Pathname to a Restricted Directory in Jenkins Google OAuth Credentials Plugin","modified":"2023-11-08T04:00:51.355828Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:google-oauth-plugin","purl":"pkg:maven/org.jenkins-ci.plugins/google-oauth-plugin","ranges":["<0.10"],"fixed":["0.10"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}