{"cve":"CVE-2019-10396","nvd":{"published":"2019-09-12T14:15:11.537","modified":"2026-06-17T02:10:51.497","status":"Modified","description":"Jenkins Dashboard View Plugin 2.11 and earlier did not escape build descriptions, resulting in a cross-site scripting vulnerability exploitable by users able to change build descriptions.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2019/09/12/2","https://jenkins.io/security/advisory/2019-09-12/#SECURITY-1489","http://www.openwall.com/lists/oss-security/2019/09/12/2","https://jenkins.io/security/advisory/2019-09-12/#SECURITY-1489"],"products":["jenkins:dashboard_view"],"source":"nvd","synced_at":"2026-10-19T20:58:39.700375520+00:00"},"epss":{"cve":"CVE-2019-10396","score":0.00735,"percentile":0.54443,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-fv4q-4h24-23qr","url":"https://osv.dev/vulnerability/GHSA-fv4q-4h24-23qr","summary":"Jenkins Dashboard View Plugin vulnerable to Cross-site Scripting","modified":"2024-02-16T08:17:00.960356Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:dashboard-view","purl":"pkg:maven/org.jenkins-ci.plugins/dashboard-view","ranges":["<2.12"],"fixed":["2.12"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}