{"cve":"CVE-2019-10206","nvd":{"published":"2019-11-22T13:15:11.723","modified":"2026-06-17T02:10:29.290","status":"Modified","description":"ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","score":6.5},"cwes":["CWE-522"],"references":["http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html","http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10206","https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html","https://www.debian.org/security/2021/dsa-4950"],"products":["debian:debian_linux","opensuse:backports_sle","opensuse:leap","redhat:ansible"],"source":"nvd","synced_at":"2026-10-19T20:59:25.448946135+00:00"},"epss":{"cve":"CVE-2019-10206","score":0.01515,"percentile":0.74519,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-cqmr-rcpr-cxh3","url":"https://osv.dev/vulnerability/GHSA-cqmr-rcpr-cxh3","summary":"Ansible password prompts could expose passwords","modified":"2024-11-25T05:23:22.828959Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.8.0 <2.8.4"],"fixed":["2.8.4"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.7.0 <2.7.13"],"fixed":["2.7.13"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.6.0 <2.6.19"],"fixed":["2.6.19"]}]},{"id":"PYSEC-2019-145","url":"https://osv.dev/vulnerability/PYSEC-2019-145","summary":"","modified":"2026-06-10T17:00:15.947216023Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.6.0 <2.6.19",">=2.7.0 <2.7.13",">=2.8.0 <2.8.4"],"fixed":["2.6.19","2.7.13","2.8.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}