{"cve":"CVE-2019-1003022","nvd":{"published":"2019-02-06T16:29:01.030","modified":"2026-06-17T02:09:33.477","status":"Modified","description":"A denial of service vulnerability exists in Jenkins Monitoring Plugin 1.74.0 and earlier in PluginImpl.java that allows attackers to kill threads running on the Jenkins master.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","score":6.5},"cwes":["CWE-352"],"references":["https://jenkins.io/security/advisory/2019-01-28/#SECURITY-1153","https://jenkins.io/security/advisory/2019-01-28/#SECURITY-1153"],"products":["jenkins:monitoring"],"source":"nvd","synced_at":"2026-10-19T20:54:46.948512734+00:00"},"epss":{"cve":"CVE-2019-1003022","score":0.00735,"percentile":0.54459,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-hw83-jpxr-g225","url":"https://osv.dev/vulnerability/GHSA-hw83-jpxr-g225","summary":"Jenkins Monitoring Plugin vulnerable to Denial of service vulnerability","modified":"2024-02-16T08:17:12.406066Z","packages":[{"ecosystem":"Maven","name":"org.jvnet.hudson.plugins:monitoring","purl":"pkg:maven/org.jvnet.hudson.plugins/monitoring","ranges":["<1.75.0"],"fixed":["1.75.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}