{"cve":"CVE-2019-1003006","nvd":{"published":"2019-02-06T16:29:00.407","modified":"2026-06-17T02:09:31.600","status":"Modified","description":"A sandbox bypass vulnerability exists in Jenkins Groovy Plugin 2.0 and earlier in src/main/java/hudson/plugins/groovy/StringScriptSource.java that allows attackers with Overall/Read permission to provide a Groovy script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-862"],"references":["https://jenkins.io/security/advisory/2019-01-28/#SECURITY-1293","https://jenkins.io/security/advisory/2019-01-28/#SECURITY-1293"],"products":["jenkins:groovy"],"source":"nvd","synced_at":"2026-10-19T20:54:46.948512734+00:00"},"epss":{"cve":"CVE-2019-1003006","score":0.0155,"percentile":0.75088,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-xfwj-2f34-32f5","url":"https://osv.dev/vulnerability/GHSA-xfwj-2f34-32f5","summary":"Jenkins Groovy Plugin sandbox bypass vulnerability","modified":"2024-02-16T08:12:41.107622Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:groovy","purl":"pkg:maven/org.jenkins-ci.plugins/groovy","ranges":["<2.1"],"fixed":["2.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}