{"cve":"CVE-2018-9861","nvd":{"published":"2018-04-19T17:29:00.257","modified":"2026-06-17T02:07:18.500","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, allows remote attackers to inject arbitrary web script through a crafted IMG element.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://www.securityfocus.com/bid/103924","https://github.com/ckeditor/ckeditor-dev/blob/master/CHANGES.md","https://www.drupal.org/sa-core-2018-003","https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html","http://www.securityfocus.com/bid/103924"],"products":["ckeditor:enhanced_image","drupal:drupal"],"source":"nvd","synced_at":"2026-10-19T20:49:59.483420567+00:00"},"epss":{"cve":"CVE-2018-9861","score":0.01719,"percentile":0.77463,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-g78h-pf65-46rv","url":"https://osv.dev/vulnerability/GHSA-g78h-pf65-46rv","summary":"Enhanced Image plugin for CKEditor is vulnerable to Cross-site scripting (XSS)","modified":"2025-12-10T23:41:15.971028Z","packages":[{"ecosystem":"Packagist","name":"drupal/core","purl":"pkg:composer/drupal/core","ranges":[">=8.5.0 <8.5.2"],"fixed":["8.5.2"]},{"ecosystem":"npm","name":"ckeditor-dev","purl":"pkg:npm/ckeditor-dev","ranges":[">=4.5.10 <4.9.2"],"fixed":["4.9.2"]},{"ecosystem":"Packagist","name":"drupal/core","purl":"pkg:composer/drupal/core","ranges":[">=8.0 <8.4.7"],"fixed":["8.4.7"]},{"ecosystem":"Packagist","name":"drupal/drupal","purl":"pkg:composer/drupal/drupal","ranges":[">=8.0 <8.4.7"],"fixed":["8.4.7"]},{"ecosystem":"Packagist","name":"drupal/drupal","purl":"pkg:composer/drupal/drupal","ranges":[">=8.5 <8.5.2"],"fixed":["8.5.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}