{"cve":"CVE-2018-7651","nvd":{"published":"2018-03-04T01:29:00.347","modified":"2026-06-17T02:03:28.777","status":"Modified","description":"index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","score":5.9},"cwes":["CWE-400"],"references":["https://github.com/zkat/ssri/commit/d0ebcdc22cb5c8f47f89716d08b3518b2485d65d","https://github.com/zkat/ssri/issues/10","https://nodesecurity.io/advisories/565","https://github.com/zkat/ssri/commit/d0ebcdc22cb5c8f47f89716d08b3518b2485d65d","https://github.com/zkat/ssri/issues/10"],"products":["ssri_project:ssri"],"source":"nvd","synced_at":"2026-10-19T20:48:50.842038930+00:00"},"epss":{"cve":"CVE-2018-7651","score":0.01714,"percentile":0.77396,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-325j-24f4-qv5x","url":"https://osv.dev/vulnerability/GHSA-325j-24f4-qv5x","summary":"Regular Expression Denial of Service in ssri","modified":"2023-11-08T04:00:23.259650Z","packages":[{"ecosystem":"npm","name":"ssri","purl":"pkg:npm/ssri","ranges":["<5.2.2"],"fixed":["5.2.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}