{"cve":"CVE-2018-7575","nvd":{"published":"2019-04-24T21:29:00.570","modified":"2026-06-17T02:03:24.067","status":"Modified","description":"Google TensorFlow 1.7.x and earlier is affected by a Buffer Overflow vulnerability. The type of exploitation is context-dependent.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-190"],"references":["https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-004.md","https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-004.md"],"products":["google:tensorflow"],"source":"nvd","synced_at":"2026-10-19T20:56:19.218283075+00:00"},"epss":{"cve":"CVE-2018-7575","score":0.00614,"percentile":0.49407,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-mw6v-crh8-8533","url":"https://osv.dev/vulnerability/GHSA-mw6v-crh8-8533","summary":"Integer Overflow or Wraparound in Google TensorFlow","modified":"2024-10-28T14:43:23.082498Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":[">=1.0.0 <1.7.1"],"fixed":["1.7.1"]},{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":[">=1.0.0 <1.7.1"],"fixed":["1.7.1"]}]},{"id":"PYSEC-2019-205","url":"https://osv.dev/vulnerability/PYSEC-2019-205","summary":"","modified":"2023-11-08T04:00:23.059640Z","packages":[{"ecosystem":"PyPI","name":"tensorflow","purl":"pkg:pypi/tensorflow","ranges":["<1.7.1"],"fixed":["1.7.1"]}]},{"id":"PYSEC-2019-223","url":"https://osv.dev/vulnerability/PYSEC-2019-223","summary":"","modified":"2023-11-08T04:00:23.059640Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-cpu","purl":"pkg:pypi/tensorflow-cpu","ranges":["<1.7.1"],"fixed":["1.7.1"]}]},{"id":"PYSEC-2019-230","url":"https://osv.dev/vulnerability/PYSEC-2019-230","summary":"","modified":"2026-06-10T17:02:43.206479372Z","packages":[{"ecosystem":"PyPI","name":"tensorflow-gpu","purl":"pkg:pypi/tensorflow-gpu","ranges":["<1.7.1"],"fixed":["1.7.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}