{"cve":"CVE-2018-6184","nvd":{"published":"2018-01-24T10:29:01.020","modified":"2026-06-17T02:01:28.380","status":"Modified","description":"ZEIT Next.js 4 before 4.2.3 has Directory Traversal under the /_next request namespace.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-22"],"references":["https://github.com/zeit/next.js/releases/tag/4.2.3","https://github.com/zeit/next.js/releases/tag/4.2.3"],"products":["zeit:next.js"],"source":"nvd","synced_at":"2026-10-19T20:48:34.567387330+00:00"},"epss":{"cve":"CVE-2018-6184","score":0.0906,"percentile":0.95288,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-m34x-wgrh-g897","url":"https://osv.dev/vulnerability/GHSA-m34x-wgrh-g897","summary":"Directory traversal vulnerability in Next.js","modified":"2023-11-08T04:00:21.025418Z","packages":[{"ecosystem":"npm","name":"next","purl":"pkg:npm/next","ranges":[">=1.0.0 <4.2.3"],"fixed":["4.2.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}