{"cve":"CVE-2018-3777","nvd":{"published":"2018-08-03T20:29:00.297","modified":"2026-06-17T01:57:48.650","status":"Modified","description":"Insufficient URI encoding in restforce before 3.0.0 allows attacker to inject arbitrary parameters into Salesforce API requests.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-172","CWE-20"],"references":["https://github.com/restforce/restforce/pull/392","https://github.com/restforce/restforce/pull/392"],"products":["restforce:restforce"],"source":"nvd","synced_at":"2026-10-19T20:52:03.425131697+00:00"},"epss":{"cve":"CVE-2018-3777","score":0.01506,"percentile":0.74367,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-534w-937m-v7x3","url":"https://osv.dev/vulnerability/GHSA-534w-937m-v7x3","summary":"restforce vulnerable to Improper Input Validation","modified":"2024-02-16T08:08:58.530532Z","packages":[{"ecosystem":"RubyGems","name":"restforce","purl":"pkg:gem/restforce","ranges":["<3.0.0"],"fixed":["3.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}