{"cve":"CVE-2018-3746","nvd":{"published":"2018-06-01T17:29:00.610","modified":"2026-06-17T01:57:45.700","status":"Modified","description":"The pdfinfojs NPM module versions <= 0.3.6 has a command injection vulnerability that allows an attacker to execute arbitrary commands on the victim's machine.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-78","CWE-77"],"references":["https://hackerone.com/reports/330957","https://hackerone.com/reports/330957"],"products":["pdfinfojs_project:pdfinfojs"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2018-3746","score":0.04853,"percentile":0.92028,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-3pxp-6963-46r9","url":"https://osv.dev/vulnerability/GHSA-3pxp-6963-46r9","summary":"Command Injection in pdfinfojs","modified":"2023-11-08T04:00:18.596470Z","packages":[{"ecosystem":"npm","name":"pdfinfojs","purl":"pkg:npm/pdfinfojs","ranges":["<0.4.1"],"fixed":["0.4.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}