{"cve":"CVE-2018-3739","nvd":{"published":"2018-06-07T02:29:08.973","modified":"2026-06-17T01:57:45.080","status":"Modified","description":"https-proxy-agent before 2.1.1 passes auth option to the Buffer constructor without proper sanitization, resulting in DoS and uninitialized memory leak in setups where an attacker could submit typed input to the 'auth' parameter (e.g. JSON).","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","score":9.1},"cwes":["CWE-125","CWE-400"],"references":["https://hackerone.com/reports/319532","https://hackerone.com/reports/319532"],"products":["https-proxy-agent_project:https-proxy-agent"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2018-3739","score":0.01735,"percentile":0.77676,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-8g7p-74h8-hg48","url":"https://osv.dev/vulnerability/GHSA-8g7p-74h8-hg48","summary":"Denial of Service in https-proxy-agent","modified":"2026-09-10T03:46:37.019903328Z","packages":[{"ecosystem":"npm","name":"https-proxy-agent","purl":"pkg:npm/https-proxy-agent","ranges":["<2.2.0"],"fixed":["2.2.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}