{"cve":"CVE-2018-3717","nvd":{"published":"2018-06-07T02:29:08.130","modified":"2026-06-17T01:57:42.950","status":"Modified","description":"connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["https://github.com/senchalabs/connect/commit/6d5dd30075d2bc4ee97afdbbe3d9d98d8d52d74b","https://hackerone.com/reports/309394","https://hackerone.com/reports/309641","https://github.com/senchalabs/connect/commit/6d5dd30075d2bc4ee97afdbbe3d9d98d8d52d74b","https://hackerone.com/reports/309394"],"products":["sencha:connect"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2018-3717","score":0.01306,"percentile":0.70551,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-rch9-xh7r-mqgw","url":"https://osv.dev/vulnerability/GHSA-rch9-xh7r-mqgw","summary":"Cross-Site Scripting in connect","modified":"2023-11-08T04:00:16.936418Z","packages":[{"ecosystem":"npm","name":"connect","purl":"pkg:npm/connect","ranges":["<2.14.0"],"fixed":["2.14.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}