{"cve":"CVE-2018-25088","nvd":{"published":"2023-07-18T13:15:11.187","modified":"2026-06-17T01:54:41.520","status":"Modified","description":"A vulnerability, which was classified as critical, was found in Blue Yonder postgraas_server up to 2.0.0b2. Affected is the function _create_pg_connection/create_postgres_db of the file postgraas_server/backends/postgres_cluster/postgres_cluster_driver.py of the component PostgreSQL Backend Handler. The manipulation leads to sql injection. Upgrading to version 2.0.0 is able to address this issue. The patch is identified as 7cd8d016edc74a78af0d81c948bfafbcc93c937c. It is recommended to upgrade the affected component. VDB-234246 is the identifier assigned to this vulnerability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-89"],"references":["https://github.com/blue-yonder/postgraas_server/commit/7cd8d016edc74a78af0d81c948bfafbcc93c937c","https://github.com/blue-yonder/postgraas_server/releases/tag/v2.0.0","https://vuldb.com/?ctiid.234246","https://vuldb.com/?id.234246","https://github.com/blue-yonder/postgraas_server/commit/7cd8d016edc74a78af0d81c948bfafbcc93c937c"],"products":["blueyonder:postgraas_server"],"source":"nvd","synced_at":"2026-10-19T21:38:35.729974749+00:00"},"epss":{"cve":"CVE-2018-25088","score":0.00732,"percentile":0.54347,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-vghm-8cjp-hjw6","url":"https://osv.dev/vulnerability/GHSA-vghm-8cjp-hjw6","summary":"postgraas-server vulnerable to SQL injection","modified":"2026-06-29T12:26:06.689522249Z","packages":[{"ecosystem":"PyPI","name":"postgraas-server","purl":"pkg:pypi/postgraas-server","ranges":["<2.0.0"],"fixed":["2.0.0"]}]},{"id":"PYSEC-2026-460","url":"https://osv.dev/vulnerability/PYSEC-2026-460","summary":"postgraas-server vulnerable to SQL injection","modified":"2026-07-01T20:23:00.973281Z","packages":[{"ecosystem":"PyPI","name":"postgraas-server","purl":"pkg:pypi/postgraas-server","ranges":["<2.0.0"],"fixed":["2.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}