{"cve":"CVE-2018-25058","nvd":{"published":"2022-12-29T08:15:08.620","modified":"2026-06-17T01:54:37.420","status":"Modified","description":"A vulnerability classified as problematic has been found in Twitter-Post-Fetcher up to 17.x. This affects an unknown part of the file js/twitterFetcher.js of the component Link Target Handler. The manipulation leads to use of web link to untrusted target with window.opener access. It is possible to initiate the attack remotely. Upgrading to version 18.0.0 is able to address this issue. The name of the patch is 7d281c6fb5acbc29a2cad295262c1f0c19ca56f3. It is recommended to upgrade the affected component. The identifier VDB-217017 was assigned to this vulnerability.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-1022"],"references":["https://github.com/jasonmayes/Twitter-Post-Fetcher/commit/7d281c6fb5acbc29a2cad295262c1f0c19ca56f3","https://github.com/jasonmayes/Twitter-Post-Fetcher/pull/170","https://github.com/jasonmayes/Twitter-Post-Fetcher/releases/tag/18.0.0","https://vuldb.com/?ctiid.217017","https://vuldb.com/?id.217017"],"products":["twitter-post-fetcher_project:twitter-post-fetcher"],"source":"nvd","synced_at":"2026-10-19T21:37:31.370122805+00:00"},"epss":{"cve":"CVE-2018-25058","score":0.00562,"percentile":0.46757,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-m688-cx2p-rgq9","url":"https://osv.dev/vulnerability/GHSA-m688-cx2p-rgq9","summary":"Twitter-Post-Fetcher vulnerable to Use of Web Link to Untrusted Target with window.opener Access","modified":"2023-11-08T04:00:15.652844Z","packages":[{"ecosystem":"npm","name":"twitter-fetcher-js","purl":"pkg:npm/twitter-fetcher-js","ranges":["<18.0.0"],"fixed":["18.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}