{"cve":"CVE-2018-18282","nvd":{"published":"2018-10-12T22:29:00.763","modified":"2026-06-17T01:46:56.197","status":"Modified","description":"Next.js 7.0.0 and 7.0.1 has XSS via the 404 or 500 /_error page.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/zeit/next.js/releases/tag/7.0.2","https://github.com/zeit/next.js/releases/tag/7.0.2"],"products":["zeit:next.js"],"source":"nvd","synced_at":"2026-10-19T20:53:59.789560037+00:00"},"epss":{"cve":"CVE-2018-18282","score":0.0103,"percentile":0.63717,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qw96-mm2g-c8m7","url":"https://osv.dev/vulnerability/GHSA-qw96-mm2g-c8m7","summary":"Next.js has cross site scripting (XSS) vulnerability via the 404 or 500 /_error page","modified":"2023-11-08T04:00:05.061101Z","packages":[{"ecosystem":"npm","name":"next","purl":"pkg:npm/next","ranges":[">=7.0.0 <7.0.2"],"fixed":["7.0.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}