{"cve":"CVE-2018-16876","nvd":{"published":"2019-01-03T15:29:01.163","modified":"2026-06-17T01:44:58.297","status":"Modified","description":"ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N","score":5.3},"cwes":["CWE-200"],"references":["http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00021.html","http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00077.html","http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00020.html","http://www.securityfocus.com/bid/106225","https://access.redhat.com/errata/RHSA-2018:3835"],"products":["canonical:ubuntu_linux","debian:debian_linux","redhat:ansible","redhat:ansible_engine","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation","redhat:openstack","suse:package_hub"],"source":"nvd","synced_at":"2026-10-19T20:54:36.112582389+00:00"},"epss":{"cve":"CVE-2018-16876","score":0.02483,"percentile":0.84597,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-j569-fghw-f9rx","url":"https://osv.dev/vulnerability/GHSA-j569-fghw-f9rx","summary":"Ansible sensitive information disclosure","modified":"2024-11-21T05:23:38.377915Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":["<2.5.14"],"fixed":["2.5.14"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.6.0a1 <2.6.11"],"fixed":["2.6.11"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.7.0a1 <2.7.5"],"fixed":["2.7.5"]}]},{"id":"PYSEC-2019-141","url":"https://osv.dev/vulnerability/PYSEC-2019-141","summary":"","modified":"2026-06-10T17:00:18.594019081Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.5.0 <2.5.14",">=2.6.0 <2.6.11",">=2.7.0 <2.7.5"],"fixed":["2.5.14","2.6.11","2.7.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}