{"cve":"CVE-2018-16470","nvd":{"published":"2018-11-13T23:29:00.263","modified":"2026-06-17T01:44:20.943","status":"Modified","description":"There is a possible DoS vulnerability in the multipart parser in Rack before 2.0.6. Specially crafted requests can cause the multipart parser to enter a pathological state, causing the parser to use CPU resources disproportionate to the request size.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-400"],"references":["https://access.redhat.com/errata/RHSA-2019:3172","https://groups.google.com/forum/#%21msg/rubyonrails-security/U_x-YkfuVTg/xhvYAmp6AAAJ","https://access.redhat.com/errata/RHSA-2019:3172","https://groups.google.com/forum/#%21msg/rubyonrails-security/U_x-YkfuVTg/xhvYAmp6AAAJ"],"products":["rack_project:rack"],"source":"nvd","synced_at":"2026-10-19T20:53:59.789560037+00:00"},"epss":{"cve":"CVE-2018-16470","score":0.02033,"percentile":0.81067,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-hg78-4f6x-99wq","url":"https://osv.dev/vulnerability/GHSA-hg78-4f6x-99wq","summary":"Rack vulnerable to Denial of Service","modified":"2024-02-16T08:02:29.993945Z","packages":[{"ecosystem":"RubyGems","name":"rack","purl":"pkg:gem/rack","ranges":[">=2.0.4 <2.0.6"],"fixed":["2.0.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}