{"cve":"CVE-2018-16460","nvd":{"published":"2018-09-07T18:29:00.497","modified":"2026-06-17T01:44:19.803","status":"Modified","description":"A command Injection in ps package versions <1.0.0 for Node.js allowed arbitrary commands to be executed when attacker controls the PID.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-78","CWE-77"],"references":["https://hackerone.com/reports/390848","https://hackerone.com/reports/390848"],"products":["umbraengineering:ps"],"source":"nvd","synced_at":"2026-10-19T20:53:14.491561039+00:00"},"epss":{"cve":"CVE-2018-16460","score":0.02856,"percentile":0.86736,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-cfhg-9x44-78h2","url":"https://osv.dev/vulnerability/GHSA-cfhg-9x44-78h2","summary":"ps Enables OS Command Injection","modified":"2023-11-08T03:59:59.454657Z","packages":[{"ecosystem":"npm","name":"ps","purl":"pkg:npm/ps","ranges":["<1.0.0"],"fixed":["1.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}