{"cve":"CVE-2018-15758","nvd":{"published":"2018-10-18T22:29:00.537","modified":"2026-06-17T01:43:04.030","status":"Modified","description":"Spring Security OAuth, versions 2.3 prior to 2.3.4, and 2.2 prior to 2.2.3, and 2.1 prior to 2.1.3, and 2.0 prior to 2.0.16, and older unsupported versions could be susceptible to a privilege escalation under certain conditions. A malicious user or attacker can craft a request to the approval endpoint that can modify the previously saved authorization request and lead to a privilege escalation on the subsequent approval. This scenario can happen if the application is configured to use a custom approval endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability exposes applications that meet all of the following requirements: Act in the role of an Authorization Server (e.g. @EnableAuthorizationServer) and use a custom Approval Endpoint that declares AuthorizationRequest as a controller method argument. This vulnerability does not expose applications that: Act in the role of an Authorization Server and use the default Approval Endpoint, act in the role of a Resource Server only (e.g. @EnableResourceServer), act in the role of a Client only (e.g. @EnableOAuthClient).","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","score":8.1},"cwes":[],"references":["http://www.securityfocus.com/bid/105687","https://access.redhat.com/errata/RHSA-2019:2413","https://pivotal.io/security/cve-2018-15758","http://www.securityfocus.com/bid/105687","https://access.redhat.com/errata/RHSA-2019:2413"],"products":["pivotal_software:spring_security_oauth"],"source":"nvd","synced_at":"2026-10-19T20:53:59.789560037+00:00"},"epss":{"cve":"CVE-2018-15758","score":0.02153,"percentile":0.82161,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-h8w4-qv99-f7vj","url":"https://osv.dev/vulnerability/GHSA-h8w4-qv99-f7vj","summary":"Authorization bypass in org.springframework.security.oauth:spring-security-oauth2","modified":"2024-03-04T21:31:06.766684Z","packages":[{"ecosystem":"Maven","name":"org.springframework.security.oauth:spring-security-oauth2","purl":"pkg:maven/org.springframework.security.oauth/spring-security-oauth2","ranges":[">=2.0.0 <2.0.16"],"fixed":["2.0.16"]},{"ecosystem":"Maven","name":"org.springframework.security.oauth:spring-security-oauth2","purl":"pkg:maven/org.springframework.security.oauth/spring-security-oauth2","ranges":[">=2.1.0 <2.1.3"],"fixed":["2.1.3"]},{"ecosystem":"Maven","name":"org.springframework.security.oauth:spring-security-oauth2","purl":"pkg:maven/org.springframework.security.oauth/spring-security-oauth2","ranges":[">=2.2.0 <2.2.3.RELEASE"],"fixed":["2.2.3.RELEASE"]},{"ecosystem":"Maven","name":"org.springframework.security.oauth:spring-security-oauth2","purl":"pkg:maven/org.springframework.security.oauth/spring-security-oauth2","ranges":[">=2.3.0 <2.3.4.RELEASE"],"fixed":["2.3.4.RELEASE"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}