{"cve":"CVE-2018-14040","nvd":{"published":"2018-07-13T14:29:00.213","modified":"2026-06-17T01:40:31.347","status":"Modified","description":"In Bootstrap before 4.1.2, XSS is possible in the collapse data-parent attribute.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://packetstormsecurity.com/files/152787/dotCMS-5.1.1-Vulnerable-Dependencies.html","http://packetstormsecurity.com/files/156743/OctoberCMS-Insecure-Dependencies.html","http://seclists.org/fulldisclosure/2019/May/10","http://seclists.org/fulldisclosure/2019/May/11","http://seclists.org/fulldisclosure/2019/May/13"],"products":["debian:debian_linux","getbootstrap:bootstrap"],"source":"nvd","synced_at":"2026-10-19T20:52:03.425131697+00:00"},"epss":{"cve":"CVE-2018-14040","score":0.04135,"percentile":0.90834,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-3wqf-4x89-9g79","url":"https://osv.dev/vulnerability/GHSA-3wqf-4x89-9g79","summary":"Bootstrap vulnerable to Cross-Site Scripting (XSS)","modified":"2026-09-10T03:49:30.782545493Z","packages":[{"ecosystem":"npm","name":"bootstrap","purl":"pkg:npm/bootstrap","ranges":[">=4.0.0 <4.1.2"],"fixed":["4.1.2"]},{"ecosystem":"RubyGems","name":"bootstrap","purl":"pkg:gem/bootstrap","ranges":[">=4.0.0 <4.1.2"],"fixed":["4.1.2"]},{"ecosystem":"npm","name":"bootstrap","purl":"pkg:npm/bootstrap","ranges":[">=2.3.0 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"RubyGems","name":"bootstrap","purl":"pkg:gem/bootstrap","ranges":[">=2.3.0 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"Maven","name":"org.webjars:bootstrap","purl":"pkg:maven/org.webjars/bootstrap","ranges":[">=4.0.0 <4.1.2"],"fixed":["4.1.2"]},{"ecosystem":"Maven","name":"org.webjars:bootstrap","purl":"pkg:maven/org.webjars/bootstrap","ranges":[">=2.3.0 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"NuGet","name":"bootstrap","purl":"pkg:nuget/bootstrap","ranges":[">=2.3.0 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"NuGet","name":"bootstrap","purl":"pkg:nuget/bootstrap","ranges":[">=4.0.0 <4.1.2"],"fixed":["4.1.2"]},{"ecosystem":"NuGet","name":"bootstrap.sass","purl":"pkg:nuget/bootstrap.sass","ranges":[">=4.0.0 <4.1.2"],"fixed":["4.1.2"]},{"ecosystem":"RubyGems","name":"bootstrap-sass","purl":"pkg:gem/bootstrap-sass","ranges":[">=2.3.0 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"Packagist","name":"twbs/bootstrap","purl":"pkg:composer/twbs/bootstrap","ranges":[">=2.3.0 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"Packagist","name":"twbs/bootstrap","purl":"pkg:composer/twbs/bootstrap","ranges":[">=4.0.0 <4.1.2"],"fixed":["4.1.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}