{"cve":"CVE-2018-1310","nvd":{"published":"2018-05-23T14:29:00.450","modified":"2026-06-17T01:50:59.173","status":"Modified","description":"Apache NiFi JMS Deserialization issue because of ActiveMQ client vulnerability. Malicious JMS content could cause denial of service. See ActiveMQ CVE-2015-5254 announcement for more information. The fix to upgrade the activemq-client library to 5.15.3 was applied on the Apache NiFi 1.6.0 release. Users running a prior 1.x release should upgrade to the appropriate release.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-502"],"references":["https://nifi.apache.org/security.html#CVE-2018-1310","https://nifi.apache.org/security.html#CVE-2018-1310"],"products":["apache:nifi"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2018-1310","score":0.03176,"percentile":0.88051,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-p76j-5v6v-6c22","url":"https://osv.dev/vulnerability/GHSA-p76j-5v6v-6c22","summary":"Apache NiFi JMS Deserialization issue","modified":"2023-11-08T03:59:52.526665Z","packages":[{"ecosystem":"Maven","name":"org.apache.nifi:nifi","purl":"pkg:maven/org.apache.nifi/nifi","ranges":["<1.6.0"],"fixed":["1.6.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}