{"cve":"CVE-2018-11615","nvd":{"published":"2018-08-30T12:29:00.437","modified":"2026-06-17T01:36:14.920","status":"Modified","description":"This vulnerability allows remote attackers to deny service on vulnerable installations of npm mosca 2.8.1. Authentication is not required to exploit this vulnerability. The specific flaw exists within the processing of topics. A crafted regular expression can cause the broker to crash. An attacker can leverage this vulnerability to deny access to the target system. Was ZDI-CAN-6306.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-185","CWE-20"],"references":["https://zerodayinitiative.com/advisories/ZDI-18-583","https://zerodayinitiative.com/advisories/ZDI-18-583"],"products":["mosca_project:mosca"],"source":"nvd","synced_at":"2026-10-19T20:53:14.491561039+00:00"},"epss":{"cve":"CVE-2018-11615","score":0.03346,"percentile":0.88672,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-wqg7-vrj7-v82h","url":"https://osv.dev/vulnerability/GHSA-wqg7-vrj7-v82h","summary":"Mosca REDoS Vulnerability","modified":"2023-11-08T03:59:46.329633Z","packages":[{"ecosystem":"npm","name":"mosca","purl":"pkg:npm/mosca","ranges":["<2.8.2"],"fixed":["2.8.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}