{"cve":"CVE-2018-1000402","nvd":{"published":"2018-07-09T13:29:00.257","modified":"2026-06-17T01:32:43.943","status":"Modified","description":"Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","score":4.3},"cwes":["CWE-200"],"references":["https://jenkins.io/security/advisory/2018-06-25/#SECURITY-825","https://jenkins.io/security/advisory/2018-06-25/#SECURITY-825"],"products":["jenkins:aws_codedeploy"],"source":"nvd","synced_at":"2026-10-19T20:51:47.459859389+00:00"},"epss":{"cve":"CVE-2018-1000402","score":0.00967,"percentile":0.6175,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-644j-jcc4-crx7","url":"https://osv.dev/vulnerability/GHSA-644j-jcc4-crx7","summary":"Jenkins AWS CodeDeploy Plugin has Insufficiently Protected Credentials","modified":"2023-11-08T03:59:37.910083Z","packages":[{"ecosystem":"Maven","name":"com.amazonaws:codedeploy","purl":"pkg:maven/com.amazonaws/codedeploy","ranges":["<1.20"],"fixed":["1.20"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}