{"cve":"CVE-2018-1000401","nvd":{"published":"2018-07-09T13:29:00.210","modified":"2026-06-17T01:32:43.810","status":"Modified","description":"Jenkins project Jenkins AWS CodePipeline Plugin version 0.36 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodePipelineSCM.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to have been fixed in 0.37 and later.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-522"],"references":["https://jenkins.io/security/advisory/2018-06-25/#SECURITY-967","https://jenkins.io/security/advisory/2018-06-25/#SECURITY-967"],"products":["jenkins:aws_codepipeline"],"source":"nvd","synced_at":"2026-10-19T20:51:47.459859389+00:00"},"epss":{"cve":"CVE-2018-1000401","score":0.00339,"percentile":0.27329,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-5gwq-4275-q4qc","url":"https://osv.dev/vulnerability/GHSA-5gwq-4275-q4qc","summary":"Jenkins AWS CodePipeline Plugin has Insufficiently Protected Credentials","modified":"2026-09-10T03:49:30.600408954Z","packages":[{"ecosystem":"Maven","name":"com.amazonaws:aws-codepipeline","purl":"pkg:maven/com.amazonaws/aws-codepipeline","ranges":["<0.37"],"fixed":["0.37"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}