{"cve":"CVE-2018-1000226","nvd":{"published":"2018-08-20T20:29:01.847","modified":"2026-06-17T01:32:43.123","status":"Modified","description":"Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via \"network connectivity\". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-732"],"references":["https://github.com/cobbler/cobbler/issues/1916","https://movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api/","https://github.com/cobbler/cobbler/issues/1916","https://movermeyer.com/2018-08-02-privilege-escalation-exploits-in-cobblers-api/"],"products":["cobblerd:cobbler"],"source":"nvd","synced_at":"2026-10-19T20:52:03.425131697+00:00"},"epss":{"cve":"CVE-2018-1000226","score":0.12584,"percentile":0.96238,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-f88q-22g8-frcg","url":"https://osv.dev/vulnerability/GHSA-f88q-22g8-frcg","summary":"Cobbler Improper Validation of Security Tokens","modified":"2026-10-27T16:30:06.472547566Z","packages":[{"ecosystem":"PyPI","name":"cobbler","purl":"pkg:pypi/cobbler","ranges":["<3.0.0"],"fixed":["3.0.0"]}]},{"id":"PYSEC-2026-315","url":"https://osv.dev/vulnerability/PYSEC-2026-315","summary":"Cobbler Improper Validation of Security Tokens","modified":"2026-07-13T16:15:23.346913402Z","packages":[{"ecosystem":"PyPI","name":"cobbler","purl":"pkg:pypi/cobbler","ranges":["<3.0.0"],"fixed":["3.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}