{"cve":"CVE-2018-1000202","nvd":{"published":"2018-06-05T21:29:00.807","modified":"2026-06-17T01:32:40.283","status":"Modified","description":"A persisted cross-site scripting vulnerability exists in Jenkins Groovy Postbuild Plugin 2.3.1 and older in various Jelly files that allows attackers able to control build badge content to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4},"cwes":["CWE-79"],"references":["https://jenkins.io/security/advisory/2018-05-09/#SECURITY-821","https://jenkins.io/security/advisory/2018-05-09/#SECURITY-821"],"products":["jenkins:groovy_postbuild"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2018-1000202","score":0.00719,"percentile":0.53901,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-38ch-x695-m794","url":"https://osv.dev/vulnerability/GHSA-38ch-x695-m794","summary":"Jenkins Groovy Postbuild Plugin vulnerable to Cross-site Scripting","modified":"2023-11-08T03:59:37.482424Z","packages":[{"ecosystem":"Maven","name":"org.jvnet.hudson.plugins:groovy-postbuild","purl":"pkg:maven/org.jvnet.hudson.plugins/groovy-postbuild","ranges":["<2.4"],"fixed":["2.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}