{"cve":"CVE-2018-1000185","nvd":{"published":"2018-06-05T20:29:00.513","modified":"2026-06-17T01:32:37.973","status":"Modified","description":"A server-side request forgery vulnerability exists in Jenkins GitHub Branch Source Plugin 2.3.4 and older in Endpoint.java that allows attackers with Overall/Read access to cause Jenkins to send a GET request to a specified URL.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","score":4.3},"cwes":["CWE-918"],"references":["https://jenkins.io/security/advisory/2018-06-04/#SECURITY-806","https://jenkins.io/security/advisory/2018-06-04/#SECURITY-806"],"products":["jenkins:github_branch_source"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2018-1000185","score":0.00642,"percentile":0.50793,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9cfq-v2hm-c3xr","url":"https://osv.dev/vulnerability/GHSA-9cfq-v2hm-c3xr","summary":"Jenkins GitHub Branch Source Plugin vulnerable to Server-Side Request Forgery","modified":"2024-02-16T08:22:11.710511Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:github-branch-source","purl":"pkg:maven/org.jenkins-ci.plugins/github-branch-source","ranges":["<2.3.5"],"fixed":["2.3.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}