{"cve":"CVE-2018-1000175","nvd":{"published":"2018-05-08T15:29:00.347","modified":"2026-06-17T01:32:36.550","status":"Modified","description":"A path traversal vulnerability exists in Jenkins HTML Publisher Plugin 1.15 and older in HtmlPublisherTarget.java that allows attackers able to configure the HTML Publisher build step to override arbitrary files on the Jenkins master.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","score":6.5},"cwes":["CWE-22"],"references":["https://jenkins.io/security/advisory/2018-04-16/","https://jenkins.io/security/advisory/2018-04-16/"],"products":["jenkins:html_publisher"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2018-1000175","score":0.02663,"percentile":0.85712,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-4x63-3p7q-xmh7","url":"https://osv.dev/vulnerability/GHSA-4x63-3p7q-xmh7","summary":"Jenkins HTML Publisher Plugin path traversal vulnerability","modified":"2024-02-21T05:31:48.134224Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:htmlpublisher","purl":"pkg:maven/org.jenkins-ci.plugins/htmlpublisher","ranges":["<1.16"],"fixed":["1.16"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}