{"cve":"CVE-2018-1000104","nvd":{"published":"2018-03-13T13:29:00.357","modified":"2026-06-17T01:32:26.013","status":"Modified","description":"A plaintext storage of a password vulnerability exists in Jenkins Coverity Plugin 1.10.0 and earlier in CIMInstance.java that allows an attacker with local file system access or control of a Jenkins administrator's web browser (e.g. malicious extension) to retrieve the configured keystore and private key passwords.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":7.8},"cwes":["CWE-522"],"references":["https://jenkins.io/security/advisory/2018-02-26/#SECURITY-260","https://jenkins.io/security/advisory/2018-02-26/#SECURITY-260"],"products":["jenkins:coverity"],"source":"nvd","synced_at":"2026-10-19T20:48:50.842038930+00:00"},"epss":{"cve":"CVE-2018-1000104","score":0.00338,"percentile":0.27211,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-cghg-jcv6-4v5m","url":"https://osv.dev/vulnerability/GHSA-cghg-jcv6-4v5m","summary":"Jenkins Coverity Plugin has Insufficiently Protected Credentials","modified":"2024-02-16T08:14:44.700939Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:coverity","purl":"pkg:maven/org.jenkins-ci.plugins/coverity","ranges":["<1.11.0"],"fixed":["1.11.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}