{"cve":"CVE-2018-0499","nvd":{"published":"2018-07-02T12:29:00.220","modified":"2026-06-17T01:30:59.487","status":"Modified","description":"A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://lists.xapian.org/pipermail/xapian-discuss/2018-July/009652.html","https://trac.xapian.org/wiki/SecurityFixes/2018-07-02","https://usn.ubuntu.com/3709-1/","https://lists.xapian.org/pipermail/xapian-discuss/2018-July/009652.html","https://trac.xapian.org/wiki/SecurityFixes/2018-07-02"],"products":["canonical:ubuntu_linux","xapian:xapian-core"],"source":"nvd","synced_at":"2026-10-19T20:51:47.459859389+00:00"},"epss":{"cve":"CVE-2018-0499","score":0.01043,"percentile":0.64101,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-7qw4-w7hf-22q3","url":"https://osv.dev/vulnerability/GHSA-7qw4-w7hf-22q3","summary":"xapian-core Cross-site Scripting vulnerability","modified":"2024-02-20T05:22:53.467392Z","packages":[{"ecosystem":"RubyGems","name":"xapian-core","purl":"pkg:gem/xapian-core","ranges":["<1.4.6"],"fixed":["1.4.6"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}