{"cve":"CVE-2017-7550","nvd":{"published":"2017-11-21T17:29:00.210","modified":"2026-06-17T01:24:35.493","status":"Modified","description":"A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the \"params\" argument, and noting this in the module documentation.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-532"],"references":["https://access.redhat.com/errata/RHSA-2017:2966","https://bugzilla.redhat.com/show_bug.cgi?id=1473645","https://github.com/ansible/ansible/issues/30874","https://access.redhat.com/errata/RHSA-2017:2966","https://bugzilla.redhat.com/show_bug.cgi?id=1473645"],"products":["redhat:ansible","redhat:enterprise_linux_server"],"source":"nvd","synced_at":"2026-10-19T20:47:01.408438353+00:00"},"epss":{"cve":"CVE-2017-7550","score":0.0356,"percentile":0.89334,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-588w-w6mv-3cw5","url":"https://osv.dev/vulnerability/GHSA-588w-w6mv-3cw5","summary":"Ansible Insertion of Sensitive Information into Log File vulnerability","modified":"2024-09-04T20:21:24.723295Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.4.0.0 <2.4.1.0"],"fixed":["2.4.1.0"]},{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.3.0.0 <2.3.3.0"],"fixed":["2.3.3.0"]}]},{"id":"PYSEC-2017-4","url":"https://osv.dev/vulnerability/PYSEC-2017-4","summary":"","modified":"2026-06-10T17:00:16.467563606Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":[">=2.3.0.0 <2.3.3.0",">=2.4.0.0 <2.4.1.0"],"fixed":["2.3.3.0","2.4.1.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}