{"cve":"CVE-2017-7540","nvd":{"published":"2017-07-21T22:29:00.330","modified":"2026-06-17T01:24:34.080","status":"Modified","description":"rubygem-safemode, as used in Foreman, versions 1.3.2 and earlier are vulnerable to bypassing safe mode limitations via special Ruby syntax. This can lead to deletion of objects for which the user does not have delete permissions or possibly to privilege escalation.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-184"],"references":["https://github.com/svenfuchs/safemode/pull/23","https://github.com/svenfuchs/safemode/pull/23"],"products":["safemode_project:safemode"],"source":"nvd","synced_at":"2026-10-19T20:44:47.710380879+00:00"},"epss":{"cve":"CVE-2017-7540","score":0.01627,"percentile":0.76175,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-5vx5-9q73-wgp4","url":"https://osv.dev/vulnerability/GHSA-5vx5-9q73-wgp4","summary":"Safemode Gem Has Incomplete List of Disallowed Inputs","modified":"2024-02-16T08:16:32.843034Z","packages":[{"ecosystem":"RubyGems","name":"safemode","purl":"pkg:gem/safemode","ranges":["<1.3.2"],"fixed":["1.3.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}