{"cve":"CVE-2017-5946","nvd":{"published":"2017-02-27T07:59:00.317","modified":"2026-06-17T01:21:29.360","status":"Modified","description":"The Zip::File component in the rubyzip gem before 1.2.1 for Ruby has a directory traversal vulnerability. If a site allows uploading of .zip files, an attacker can upload a malicious file that uses \"../\" pathname substrings to write arbitrary files to the filesystem.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-22"],"references":["http://www.debian.org/security/2017/dsa-3801","http://www.securityfocus.com/bid/96445","https://github.com/rubyzip/rubyzip/issues/315","https://github.com/rubyzip/rubyzip/releases","http://www.debian.org/security/2017/dsa-3801"],"products":["debian:debian_linux","rubyzip_project:rubyzip"],"source":"nvd","synced_at":"2026-10-19T20:41:54.846948762+00:00"},"epss":{"cve":"CVE-2017-5946","score":0.03441,"percentile":0.88982,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-gcqq-w6gr-h9j9","url":"https://osv.dev/vulnerability/GHSA-gcqq-w6gr-h9j9","summary":"Directory traversal vulnerability in RubyZip","modified":"2024-02-16T08:12:37.749196Z","packages":[{"ecosystem":"RubyGems","name":"rubyzip","purl":"pkg:gem/rubyzip","ranges":["<1.2.1"],"fixed":["1.2.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}