{"cve":"CVE-2017-18905","nvd":{"published":"2020-06-19T20:15:12.087","modified":"2026-06-17T01:13:48.310","status":"Modified","description":"An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when used as an OAuth 2.0 service provider, Session invalidation was mishandled.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","score":5.3},"cwes":["CWE-613"],"references":["https://mattermost.com/security-updates/","https://mattermost.com/security-updates/"],"products":["mattermost:mattermost_server"],"source":"nvd","synced_at":"2026-10-19T21:05:42.039641217+00:00"},"epss":{"cve":"CVE-2017-18905","score":0.00775,"percentile":0.55794,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-g24c-fx4v-xg9w","url":"https://osv.dev/vulnerability/GHSA-g24c-fx4v-xg9w","summary":"Mattermost Server has Insufficient Session Expiration when used as an OAuth 2.0 service provider","modified":"2026-02-03T03:02:11.022673Z","packages":[{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":["<3.9.2"],"fixed":["3.9.2"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=3.10.0 <3.10.2"],"fixed":["3.10.2"]}]},{"id":"GO-2026-4306","url":"https://osv.dev/vulnerability/GO-2026-4306","summary":"Mattermost Server has Insufficient Session Expiration when used as an OAuth 2.0 service provider in github.com/mattermost/mattermost-server","modified":"2026-03-03T04:57:50.533953Z","packages":[{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":["<3.9.2+incompatible",">=3.10.0+incompatible <3.10.2+incompatible"],"fixed":["3.9.2+incompatible","3.10.2+incompatible"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}